my.brown.edu Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 13:50 EST

Update

My.brown.edu is currently experiencing an end user outage. OIT is investigating this issue.
Posted Feb 18, 2026 - 13:41 EST

Investigating

We are currently investigating this issue.
Posted Feb 18, 2026 - 13:40 EST
This incident affected: Communication and Collaboration (MyBrown Web Portal).