The OIT upgrade of Brown’s Departmental File Services (DFS) is now complete. Wherever possible OIT has automatically reconnected all Brown employees to the new file storage which is now known as “files22.brown.edu” instead of the previous “files.brown.edu”.
For information on how to reconnect manually, please use the following instructions:
If you need any help reconnecting to your files, please reach out to the OIT Service Center via help@brown.edu
Posted Mar 24, 2025 - 07:21 EDT
Update
OIT is currently performing an upgrade of Brown’s Departmental File Services (DFS). This service will not be available from 7 p.m. on Friday, March 21 until 7 a.m. on Monday, March 24. When this work is complete, we’ll be using a faster, more secure file storage platform for Brown. If you need help reconnecting on Monday morning, please reach out to the OIT Service Center via help@brown.edu.
Posted Mar 22, 2025 - 07:09 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 19:00 EDT
Scheduled
OIT will be performing an upgrade of Brown’s Departmental File Services (DFS) starting at 7 p.m. tonight. This service will not be available from 7 p.m. on Friday, March 21 until 7 a.m. on Monday, March 24.
If you need access to files saved on “files.brown.edu\DFS” during this scheduled outage, you can copy them in advance to your own computer for the weekend, and then copy them back on Monday.
When this work is complete, we’ll be using a faster, more secure file storage platform for Brown. If you need help reconnecting on Monday morning, please reach out to the OIT Service Center via help@brown.edu.
Posted Mar 21, 2025 - 06:36 EDT
This scheduled maintenance affected: Infrastructure (Department File Services - files.brown.edu).