Additional services may have been degraded or unresponsive during this outage including: - Academic Coaching - Advising Sidekick (ASK) - Computer Science systems - CourseTools - Faculty Activity Reporting - Faculty Hiring - LibreChat AI Chat - MyAccount - MyBrown - Scan to Ricoh Printers - Travelsafe - UFunds
OIT will continue to monitor all affected services. Please report any further problems to OIT.
Posted Dec 11, 2025 - 09:12 EST
Update
Some Oscar users have had some failed jobs due to this outage. Please resubmit your Oscar job if it appears to have failed between 7 and 8:45 a.m this morning.
Posted Dec 11, 2025 - 08:54 EST
Monitoring
The root problem has been identified and services are returning to stable. If you are unable to access files on network drives or folders on files22.brown.edu, you may need to log out and log back in to your computer to refresh your connections. OIT is continuing to validate all services.
Posted Dec 11, 2025 - 08:17 EST
Identified
We have identified the issue and are working with the vendor on a resolution.
Posted Dec 11, 2025 - 07:51 EST
Update
We are currently experiencing an outage affecting use of files22.brown.edu, including Research and Departmental shares. High performance computing, including Oscar and Globus File Transfers are also experiencing a degradation of service.
Posted Dec 11, 2025 - 07:40 EST
Update
We are continuing to investigate this issue.
Posted Dec 11, 2025 - 07:39 EST
Investigating
We are currently experiencing connectivity issues with files22.brown.edu
OIT is investigating this issue.
Posted Dec 11, 2025 - 07:27 EST
This incident affected: Infrastructure (Department File Services - files.brown.edu) and Research (Globus File Transfers, Oscar High Performance Computing, VAST - files22.brown.edu).