courses@brown is down
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Sep 26, 2024 - 08:39 EDT
Investigating
We are currently investigating this issue.
Posted Sep 26, 2024 - 07:24 EDT
This incident affected: Teaching and Learning (Course Catalog - cab.brown.edu).