Google Workspace Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 11:09 EDT

Investigating

Google is currently investigating reports of an issue affecting Google Docs, Apps Script, Google Slides, Google Drive, and Google Calendar.

If you would like to track the progress of this investigation yourself, additional details are available on the Google Workspace Status Dashboard: [https://www.google.com/appsstatus/dashboard/incidents/KamjizntSiNtRETcBL2Q]
Posted Mar 13, 2026 - 10:50 EDT
This incident affected: Communication and Collaboration (Google Drive, Google Mail).