Brown Tutoring Degredation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 08, 2024 - 16:46 EST

Investigating

Students may experience interruptions when connecting to tutoring.apps.brown.edu
Posted Feb 05, 2024 - 09:22 EST
This incident affected: Other (Other).