Brown Faculty Club Website
Incident Report for Brown University
Update
The membership portal on the Brown Faculty Club website will be down until further notice. We apologize for the inconvenience. If you need assistance with membership payments, please contact our office at 401-863-3023.
Posted Oct 02, 2024 - 14:34 EDT
Investigating
At this time the membership portal is temporarily down for maintenance. We apologize for the inconvenience. If you need assistance with membership payments, please contact our office at 401-863-3023.
Posted Aug 23, 2024 - 11:56 EDT
This incident affects: Other (Other).