Windows Machines Cannot Connect to Brown Wi-Fi

Incident Report for Brown University

Monitoring

Our updates to the client certificate profiles have been completed. Customers who have trouble connecting to the "Brown" wireless network should go to wifi.brown.edu to refresh their connection.
Posted Jul 06, 2026 - 10:23 EDT

Identified

Windows machines across campus are having issues connecting to Brown's Wi-Fi. Users can attempt to join Brown Guest.

You can reset your connection to the network by visiting wifi.brown.edu to refresh your profile. OIT is working to update network profiles for Brown-managed machines.
Posted Jul 06, 2026 - 09:00 EDT

Investigating

Windows machines across campus are having issues connecting to Brown's Wi-Fi. Users can attempt to join Brown Guest.
Posted Jul 06, 2026 - 08:15 EDT
This incident affects: Network Connectivity and Telecommunications (Wireless network (Brown, Brown-Guest, & Eduroam)).