Service Disruption - Cognos Analytics

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 11:46 EDT

Investigating

We are currently experiencing a service disruption with Cognos Analytics. Users are experiencing issues running and creating reports.

Our team is working to identify the root cause and implement a solution.
Posted Apr 27, 2026 - 11:20 EDT
This incident affected: Administrative and Business (Cognos - Analytics & Reporting).