Power Outage at Butler Hospital
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Nov 16, 2024 - 15:11 EST
Monitoring
There is a power outage at Butler Hospital, affecting Wired, Wireless, and VoIP connections at the location.
Posted Nov 16, 2024 - 13:19 EST
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).