As a result of this morning’s VPN service update, your computer’s VPN software, the ”BIG-IP Edge Client” app, will need a new version.
For Mac users, previous versions of the VPN app are unable to install the update on their own. To save you time, OIT is automatically updating clients on any Brown-managed Mac computers where VPN is already installed.
Users of Macs that are not managed by Brown will need to manually update their VPN app to continue use of the VPN. We have instructions in this instructions in this IT Help article to get and install the newest version of the VPN software. If you see any notification for changes to components related to F5 BIG-IP Edge Client when you connect to VPN after July 22, these are legitimate, and you can allow the update to happen.
For users of Windows computers, we expect most will successfully update their software automatically upon connection to the VPN. Your login may take an extra minute or so as components are updated, then you should be able to connect.
If for any reason your computer does not successfully complete the self-update, or if you want to update ahead of time to avoid disruption, please refer to our IT Help article to manually upgrade the VPN software.
If you have any questions or need help, please reach out to your IT support professional or contact the OIT Service Center via help@brown.edu.
Posted Jul 22, 2025 - 08:38 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 22, 2025 - 05:00 EDT
Scheduled
On Tuesday, July 22, from 5:00 a.m. to 8:00 a.m., Brown’s VPN service will be upgraded. While the upgrade is being completed you may experience a brief VPN disconnection.
After this change is complete, your computer’s VPN software, the ”BIG-IP Edge Client” app, will need a new version.
For Mac users, previous versions of the VPN app are unable to install the update on their own. To save you time, OIT is automatically updating clients on any Brown-managed Mac computers where VPN is already installed.
Users of Macs that are not managed by Brown will need to manually update their VPN app to continue use of the VPN. We have instructions in this IT Help article to get and install the newest version of the VPN software. If you see any notification for changes to components related to F5 BIG-IP Edge Client when you connect to VPN after July 22, these are legitimate, and you can allow the update to happen.
For users of Windows computers, we expect most will successfully update their software automatically upon connection to the VPN. Your login may take an extra minute or so as components are updated, then you should be able to connect.
If for any reason your computer does not successfully complete the self-update, or if you want to update ahead of time to avoid disruption, please refer to our IT Help article to manually upgrade the VPN software.
If you have any questions or need help, please reach out to your IT support professional or contact the OIT Service Center via help@brown.edu.
Posted Jul 21, 2025 - 14:58 EDT
This scheduled maintenance affected: Network Connectivity and Telecommunications (VPN - Virtual Private Network).