Network Outage at 182 George St.

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 11:32 EST

Investigating

There is a network outage at 182 George Street, affecting wired, wireless networking, and VOIP . OIT is investigating the incident.
Posted Feb 16, 2026 - 09:10 EST
This incident affected: Network Connectivity and Telecommunications (Telephone service (local and long distance), Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).