Brown’s Departmental File Services (DFS) upgrade is now complete

Incident Report for Brown University

Resolved

If you need any help reconnecting to your files, please reach out to the OIT Service Center via help@brown.edu.
Posted Mar 26, 2025 - 09:16 EDT

Monitoring

The OIT upgrade of Brown’s Departmental File Services (DFS) is now complete. Wherever possible, OIT has automatically reconnected all Brown employees to the new file storage, which is now known as “files22.brown.edu” instead of the previous “files.brown.edu”.

For information on how to reconnect manually, please use the following instructions:

Mac: https://ithelp.brown.edu/kb/articles/connect-to-departmental-file-services-with-macos
Windows: https://ithelp.brown.edu/kb/articles/connect-to-departmental-file-services-on-windows

If you need any help reconnecting to your files, please reach out to the OIT Service Center via help@brown.edu.
Posted Mar 24, 2025 - 07:37 EDT
This incident affected: Infrastructure (Department File Services - files.brown.edu).