Brown Sites Down

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 07:21 EST

Investigating

Cloudflare is aware of, and investigating an issue which impacts multiple customers, including Brown. OIT is monitoring this situation.
Posted Nov 18, 2025 - 07:10 EST
This incident affected: Information Security and Accounts (Brown Directory - directory.brown.edu, MyAccount - myaccount.brown.edu).