Widespread Zoom Problem

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 16:50 EDT

Update

As a temporary workaround, users can still call into Zoom meetings by telephone, or in some cases, you may want to use Google Meet in the short term for virtual meetings until Zoom resolves the global problem.
Posted Apr 16, 2025 - 16:01 EDT

Investigating

We are currently experiencing a widespread issue with Zoom. The application is unresponsive, and users are unable to connect at this time. This is acknowledged by Zoom as a global problem and they are investigating. We will update this alert as we receive more information.
Posted Apr 16, 2025 - 15:24 EDT
This incident affected: Communication and Collaboration (Zoom Meetings).