Intermittent Campus Network Issues Affecting Workday Access

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 14:58 EDT

Identified

OIT is aware some community members connected to the campus network are unable to access the Workday website. The issue has been identified and we are working to restore access as soon as possible.
Posted Aug 01, 2025 - 11:38 EDT
This incident affected: Administrative and Business (Workday).