Google Workspace Storage Errors

Incident Report for Brown University

Resolved

This incident has been resolved working with our vendor partners. Brown Google accounts should reflect the correct storage limits shortly, if not already. Please report any further issues to the OIT Service Center.
Posted Dec 31, 2025 - 08:49 EST

Update

OIT is working with our vendors to investigate and correct this issue.
Posted Dec 31, 2025 - 08:38 EST

Update

We are continuing to investigate this issue.
Posted Dec 31, 2025 - 07:43 EST

Investigating

Google Workspace (Gmail, Google Calendar, Google Drive and other services) are reporting that we are out of storage. You may have problems editing Drive files, but currently should be able to send and receive email and work with calendar events. OIT is investigating the problem.
Posted Dec 31, 2025 - 07:25 EST
This incident affected: Communication and Collaboration (Google Drive, Google Mail).