Mail Services Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 08:58 EDT

Investigating

We are currently experiencing an outage in our mail services and are unable to assist students at this time. We apologize for the inconvenience and are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Sep 04, 2025 - 13:02 EDT
This incident affected: Other (Other).