Network Degredation at Everett (13 Benevolent Street)
Incident Report for Brown University
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 08:28 EDT
Investigating
There is a network outage at Everett Hall affecting wired and wireless networking.
OIT is investigating the incident.
Posted Oct 02, 2024 - 13:51 EDT
This incident affected: Network Connectivity and Telecommunications (Wired Network, Wireless network (Brown, Brown-Guest, & Eduroam)).