T2 Iris Hosted Flex Services - Parking Pay Stations Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 12, 2026 - 14:04 EDT

Investigating

T2 Iris Hosted Flex Services are currently experiencing network and communication issues. This is impacting the pay stations in the Power Street Garage and the Parking Officer devices.

The pay stations are operating in offline mode and are accepting payments. The employee hybrid pay station is not accepting the employee hybrid code, making the machine inoperable. The officer's devices are experiencing a slowdown in service, but are functional.
Posted Mar 12, 2026 - 10:35 EDT
This incident affected: Other (Other).