Planon Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 14:37 EDT

Investigating

Planon is experiencing an unexpected outage, and you may receive an error message when attempting to log in. For critical facilities management requests, please contact the Service Response Center at 401-863-7800.
Posted Mar 09, 2026 - 09:45 EDT
This incident affected: Administrative and Business (Planon Facilities Management Portal).