Cognos Degradation

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 08:34 EST

Investigating

Some users may experience issues when attempting to authenticate into Cognos.
Posted Nov 12, 2025 - 11:33 EST
This incident affected: Administrative and Business (Cognos - Analytics & Reporting).