Multiple Brown Services Experiencing Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 12:08 EST

Investigating

Multiple Brown Services are experiencing a service outage.

These include:

- MyAccount
- Go
- UFunds
- ASK
- Course Tools
- TravelSafe
- Tutoring
- OrgChart
Posted Nov 06, 2025 - 11:57 EST
This incident affected: Other (Other), Student Services (Advising Sidekick (ASK)), and Information Security and Accounts (MyAccount - myaccount.brown.edu).