Tableau Server Outage

Incident Report for Brown University

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 10:41 EDT

Investigating

We are currently experiencing a service outage with Tableau Server. OIT is actively working to resolve this now.
Posted Sep 14, 2026 - 09:36 EDT
This incident affected: Administrative and Business (Tableau - Analytics and Visualization).